Version 5 released

DataSHIELD version 5.0.0 is now live and in the OBiBa CRAN! You can also install it from the master branches if you want.

The tutorials and documentation is being updated right now.

Let us know how you get on.

Before installing the new dsBase 5.0.0 package, make sure to delete all the older ones. If you are using Opal 2.15, there is a “Delete all” button that removes all the packages, and there associated R options and assign/aggregate methods.


Hi Yannick,

I clicked on the “delete all” button and tried unsuccessfully to install the the DataSHIELD packages again. Now I have nothing…see screen shot below:

This is what I did. See screen shot below:


Go to the Administration > R page and download the R server log file. The reason of the failure is probably in it. Could be the R version (3.5 minimum is required).


Hi Yannick,

Here you have it!



(Attachment Rserve.log_Sept 5 2019.txt is missing)

There is no file attached to your message. Not sure the policy of the forum allows that. You can email it to me directly.

Dear Yannick,

I have sent it to your personal email.

Best wishes,


Are you sure? Still not received any email from you.

And now?

(Attachment Rserve.log_Sept 5 2019.txt is missing)

Ok received.

Your server appears to not be properly configured to install R packages. When a R package is installed it needs to be compiled and in your case the compiler is missing:

/bin/sh: g++: command not found

I can also see that there are errors with other missing system libraries (search for ANTICONF ERROR in the log file, this will indicate which are the missing ones). You should contact your system administrator to fix that.

Great thanks! I’ll contact them.



I’ve installed the training environment (locally, windows) with Virtual Box and have downloaded the training Opal servers dstesting-100 and dstesting-101 for DS v. 5. Dstesting-101 works fine but dstesting-100 seems to be an old version of Opal (says @ 2017 when dstesting-101 says @ 2019). I fail to e.g. use histogram with error message " No such DataSHIELD ‘AGGREGATE’ method with name: histogramDS" in my R-session. Need a new version of dstesting-100 for the training environment to get version 5 to work?


Hi Bodil,

great that you are trying the new release!

Could you try downloading it again? We have just replaced the old VMs, so it is possible you were getting a cached link/version.

I have just tried it and it seems to be working ok for me. If it is still not working for you can you let me know which page on the wiki are you clicking links from?



Thanks Olly!

Empty the history of the browser and reload the VM did the trick!

Best, Bodil

Great! Hopefully that is the only problem you’ll have.

Hi Olly and Bodil,

I managed to install the dsBase v 5.0.0 in my server and then the dsBase 5.0.0 and dsBaseClient 5.0.0 in my VM and it seems to be working so far…

Best wishes,


Hi all,

It is worth noting some of your exciting scripts may need to be checked and updated to the new version. For that reason, it would a sensible idea to keep the older version and the new version available, so that this process can be completed with more ease.


Hi all,

When modelling I keep having the same error message: argument “data” is missing.

By the way, do I have to understand that the dsBetaTest has been removed from Obiba? I can no longer use it not re-install it in my server side…



Yes, I have removed dsBetaTest from to avoid potential conflicts. You can still install it from github, by referring to the master branch.