Tutorial problems

I’m using the DataSHIELD training environment, I’ve added some of my own tables to Opal and the DS login command worked perfectly but I use ds.dim(x = 'D') I receive the following error message:

Error in opal.list[[1]] : subscript out of bounds

modifying the command to ds.dim(x = 'D', datasources = connections) changes the error to:

Error: $ operator not defined for this S4 class

Not quite sure what I’ve done wrong, I have the DSI, DSOpal and dsBaseClient libraries loaded. Interestingly, if I use opal::datashield.login instead of DSI::datashield.login then the ds.dim and all other functions work perfectly. Did anyone else have this issue?


Can I confirm that you are using DataSHIELD 6.0/6.0.1, both client-side and server-side. If you are using 6.0, I would remove the “opal” and “opaladmin” packages. You should just use DSI.


1 Like

Thanks Stuart,

The version of dsBaseClient I have is 5.1.0; I’ll update my question once my packages have been updated.

I updated my version of R, RStudio and dsBaseClient and the error has gone. Still not quite working but different errors for a different question.

Cheers, Jack

For anyone interested, updating my version of dsBaseClient to v6.0.1 fixed this issue.