Image in tutorial on setting up the VirtualBox network adapter seems out of date

Hi all, I am new to Datashield and trying to install the training environment in Windows 10.

The screen image in your tutorial step ‘Setting up the VirtualBox network adapter’ is not the same as what I see in my Virtualbox (version 6.1.6 r137129). When I click on File -> Preferences -> Network I do not see a ‘host-only network’ tab. I only see an empty list of NAT Networks with a green plus button that allows me to specify one. When I do this I can only specify a Network CIDR, by which I am not sure how to specify both IPv4 address: and IPv4 Network Mask:

Does this mean Virtualbox made some updates to the layout of their menu structure by which your tutorial is out of date or am I doing something wrong?

Hia vvanhees,

This is actually something we are working on updating right now. New instructions ready for version 6.0 of datashield, with updated screenshots and instructions to match the new VirtualBox program, will be here in a matter of days. Please look out for v6.0 to try it out!

In the meantime, however, these are the steps to follow to get the host-only networks, ipv addresses in working order:

Setting up the VirtualBox network adapter

  • Select one of the Virtual Machines (VMs) and click on the orange cog settings on the top bar, right hand portion of the screen.
  • Inside that window and under the tab Network, ensure that
    • Under Adapter 1 , Enable Network Adapter is checked and it is Attached to: NAT.
    • Under Adapter 2 , Enable Network Adapter is checked and it is Attached to: Host-only Adapter.

  • Repeat this for the other VM by first selecting it on the list.
  • Next we need to ensure DHCP server is not enabled.
  • Click on File ,… Host Network Manager , and a new window will pop up.

  • In the window, there should be one item with the name " Virtualbox Host-Only Ethernet Adapter "

  • In the most righthand column is the “DHCP Server”. This should be unchecked- not enabled.
  • Next, rightclick on the name “Virtualbox Host-Only Ethernet Adapter”, and select Properties.

  • This will give an options bar at the bottom of this window.

  • Ensure Configure Adapter Manually is checked and
    • IPv4 address:
    • IPv4 Network Mask:

Hopefully this now makes sense.