Error in ds.glm

Dear all,

Do you have time to look at a problem with one of the cohorts concerning running ds.glm? We have an error that destroys the R-session afterwards:

inma = ds.glm(formula = ‘Data$asthma_current_MeDALL~Data$pets’, data = ‘Data’, family = ‘binomial’, datasources = opals) Iteration 1… Error: Command ‘glmDS2(Data$asthma_current_MeDALL ~ Data$pets, “binomial”, beta.vect = “0,0”, NULL, NULL, “Data”)’ failed on ‘inma’: Unexpected R server error: eval failed

We are running:

OS: RHEL/CentOS 7.5 R = 3.6.0 DataSHIELD: 5.0.0 Opal: 2.15.1

There is no output regarding the issue in the R-logging and or DataSHIELD logging. So we are on a dead trail here.

Really appreciate your help!

Dear Jose,

Is it the exact script?

What if you do thje following:

inma<- ds.glm( formula = ‘asthma_current_MeDALL~pets’, data = ‘Data’, family = ‘binomial’, checks=TRUE, datasources = opals )

How many studies do you have in opal? If only inma thenit is ok but if you have more than one but you want to run the model only for inma you should specify it like datasources = opals[x]

Also it would be good to add checks=TRUE to see if there is ap roblem with the variables.



Hi Mariona

Just seen this quickly while on a train. Try removing the Data$ at the start of the variable names. Otherwise you are declaring Data as the data frame and calling it Data$ which is sort of like Data$Data$. May not be answer but try anyway. P

Hi guys.

This may be a repeat message (as first attempt disappeared). I’ve seen this quickly on a train. Key issue should be either removing the data = argument or Data$ at the start of the names. Otherwise is Data$Data$. Also just seen this is already what Mariona suggested!! If it still doesn’t work repost it - I may have time on my next train to look again.

Cheers paul

Hi Mariona and Paul,

It was a “hardware” problem, it’s already solved. Opal/Datashiled runs over a Virtual Machine (centos 7.5) and the underlying hardware really cannot run some instructions at machine code level (invalid opcode). Checking the linux kernel log, we found the following error:

kernel: traps: Rserve[25142] trap invalid opcode ip:7f3aedb58220 sp:7fff28f34ad8 error:0 in;5de13ecf (deleted)[7f3aece57000+29b2000]

The Opal/Datashield virtual machine was moved to new location (newest hardware) and now it runs fine.

Many thanks.