R fatal error when running ds.forestplot

R session keeps aborting when running ds.forestplot (DataSHIELD v.6.2.0).

I tried keeping the model as simple as possible and restarting R and cleaning the environment, and I did manage to produce a figure once. But only about 1 out of 10 such attempts are successful and I can’t put my finger on what it is that makes R crash. Any help is appreciated!

Thanks, Carolina

Hi Carolina,

It is possible the problem with RStudio is related to “https://support.rstudio.com/hc/en-us/articles/360017886674-Troubleshooting-RStudio-Rendering-Errors” (another suggestion I read was to buy a new graphics card!).


Thank you Stuart, I will give it a try (and report back on what the solution was).

Hi Carolina,

Can you also try to make a forest plot outside DataSHIELD just to check what happens?

You can do something like this:

st1 = ds.glm(formula = ‘XXXXXX’, data = ‘XXXXXX’, family = ‘XXXXXX’, datasources = connections[‘study1’])

st2 = ds.glm(formula = ‘XXXXXX’, data = ‘XXXXXX’, family = ‘XXXXXX’, datasources = connections[‘study2’])

st3 = ds.glm(formula = ‘XXXXXX’, data = ‘XXXXXX’, family = ‘XXXXXX’, datasources = connections[‘study3’])

yi = c(st1$coefficients[“THENAMEOFEXPOSURE”,“Estimate”], st2$coefficients[“THENAMEOFEXPOSURE”,“Estimate”], st3$coefficients[“THENAMEOFEXPOSURE”,“Estimate”])

sei = c(st1$coefficients[“THENAMEOFEXPOSURE”,“Std. Error”], st2$coefficients[“THENAMEOFEXPOSURE”,“Std. Error”], st3$coefficients[“THENAMEOFEXPOSURE”,“Std. Error”])

res = metafor::rma(yi=yi, sei=sei)


Thanks again, Stuart and Demetris.

The options suggested in the link Stuart sent did not help, but we have not tried the new graphics card. The solution proposed by Demetris worked like a charm! Thanks so much!

Best, Carolina