Projects Status: "Loading: the database is being loaded, tables operations are not accessible yet"

Dear all,

Projects status (red dot) always show “Loading: the database is being loaded, tables operations are not accessible yet”.

I created the project, imported the data and everything worked fine. Then due to some reasons, I unregistered the database (mySQL and MongoDB) and re-registered again. Although the connections worked again, he previously-created projects status can no longer recover. And it always showed “Loading …”. I also tried to create a completely new project, but this time it failed with this loading error.

I’m wondering what additional operations I should do after these re-registration of the database? Thanks a lot.


Best regards, Cheng


  • There is a reload database button in the project’s settings page, have you tried it ?
  • Normally you are not supposed to be able to unregistered a database when there are projects attached. In what circumstances (the “some reasons”) was it possible ?
  • Have you restarted the opal server ?
  • Have you check for errors in the opal.log file ? (you can download it from Administration > Java Virtual Machine)


Dear Yannick

I think now the problem has been solved… It worked again after restarted the opal server.

  1. when it had this loading error, the reload database button didn’t work (it is grey color and not ‘clickable’)
  2. actually i was going to edit the mongodb as the default storage, but i didnt fill in the username and password (set by our IT department) which make it fail to connect. So i unregistered the database to see whether it worked. It is just due to my wrong operation. *AND yes, I was able to directly unregistered a database when projects are attached, which it is not supposed to work. But I don’t know why…
  3. restarting the server is required after re-registration

Thanks a lot. Best regards, K