Data Import from postgres database is no running

Hey, we try to import a database table from a postgres database via DataSHIELD Web Client. We are using the version 3.0.9. The setup of the database connection is running and during the import process we can select the table but during the data review step a error message is shown.

Our data sources has 2 columns id (datatype integer) and site (datatype integer). The table includes also two records with numeric values.

We try different constellation with the data types. But we always get the same error message.

Do anyone have idea how to solve the issue?

Thank you Hans-Jörg


It is hard to tell. I just tried the SQL import from Postgre and it worked.

Have you checked for a more detailed error message in the opal.log file? (you can download it from the web interface from Administration > Java Virtual Machine > Logs > Download Server logs)

What is the version of Postgre?

Could you dump the database’s schema?



the idea with the server log was good. The error message is Unhandled exception org.springframework.jdbc.BadSqlGrammarException: PreparedStatementCallback; bad SQL grammar [SELECT “site”, “id” FROM “KUM2” WHERE “id” IN (?, ?, ?, ?)]; nested exception is org.postgresql.util.PSQLException: ERROR: operator does not exist: integer = character varying Hint: No operator matches the given name and argument type(s). You might need to add explicit type casts.

We are using postgres 9.6. A database dump is not helpful because it is only a table with two columns and 4 records.


Could it be that the wrong data type from a previous test is stored in a catch and we must restart the docker container to reset the catch.

How and which explicit type casts can be used? I found no documentation about this topic.

Thank you Hans-Jörg


we could solve our issue with the data import. The log file information was a great help.

I would recommend the the information of data type for the ID field (character varying) should be documented. Without this information the data import can not run.

A better documentation of the data import via Web Client would be a big support for the users.

Thank you for your help Hans-Jörg